Syphon Recorder audio problem under Big Sur

Does anyone have success or experience with Syphon Recorder under Big Sur on Intel Macs?

Using VideoSync, I’m routing audio from Live 11 to Syphon Recorder via Loopback. Everything sounds fine while recording. However, in my recorded output, while video is fine, the audio is always garbled in a way that sounds like it’s playing at 10x speed followed by silence… which strike me as being related to sample rate, bit depth and/or clock. I get the same results even when removing my audio interface from the system and just using internal speaker.

Audio MIDI Setup shows Loopback at 48k 32-bit float, and my Focusrite Clarett interface at 48k 24-bit integer, but I find no control over bit depth. So I assume that CoreAudio, etc. manages differences in bit depth. The recorded file specs on my Syphon Recorder movies always show 16-bit little-endian signed integer 48k… even in tests at 44.1k! Bit depth aside, that’s just not right! And for bonus points, my recorded audio is still garbled if I set all components to 44.1.

I’m running the latest version of all components on a pretty fast Intel Mac (2018 Mac Mini 32GB RAM with Radeon RX Vega 64 8GB in eGPU cage).

I’ve tested enough combinations of software/hardware to believe that the issue is either a Syphon Recorder problem or a Big Sur audio problem (whether general or specific to my installation). My Big Sur is an upgrade from Catalina.

Syphon Recorder support and updates do not appear to be current… with no mention of Big Sur support. If someone can tell me they’re recording audio successfully with Syphon Recorder on Intel Mac running Big Sur, then it seems I can narrow it down to an anomaly with my particular OS installation and I can go further down that arcane rabbit hole.

I’m not attached to Syphon Recorder (especially if it is no longer a viable option!), so I’m also very open to alternatives for recording Live audio at the same time as VideoSync’s Syphon’d video output.

Thanks so much!

Hi Jeff,

That’s quite a head scratcher. I’ve done some testing but can’t seem to reproduce your issue with either of my two setups:

  • Intel iMac 2013, 16GB RAM, Nvidia GTX 775M 2GB, latest Catalina release
  • M1 Macbook, 16GB RAM, latest Big Sur release

My iMac is too old and unable to upgrade to Big Sur, so personally I can’t test Big Sur on an Intel machine.

I’m using Loopback as the output device for Live. Audio in the syphon recording sounds as expected. I’ve used Videosync’s demo project to do the tests.

An alternative you could try to record both is OBS, I’m curious to know if the result will be the same or not for you.

Thanks so much for looking into this, Jean-Paul. New Big Sur 11.4 update didn’t solve the issue… but OBS instead of Syphon Recorder is working. Thanks for the idea!

Related in case it helps anyone: Am now happily using Loopback. SWB Audio Capture has significant latency at this wriring (a known issue the dev says he’s working on), and I couldn’t get Blackhole working properly.

1 Like

Hi @jeffburger — were you ever able to get audio recording properly in Syphon Recorder? I’m having the same issue (I’m on MacOS Mojave). OBS works, but seems like it eats up a lot more processing power than Syphon Recorder, so not ideal for optimization…

Hi giantmecha,

I was able to finally get it working after a combo of upgrading to Big Sur 11.4, using Loopback to route audio from Live to Syphon Recorder, and switching my Syphon Recorder codec to Photo JPEG. (That means having to post-process the file into something practical like H.264, but that’s better than the alternative to date.)

That seemed to work for a while… then the problem returned. I just thought to increase Live’s buffer and it looks like 1028 might have at least temporarily resolved the issue… but I’m not convinced and have more testing to do. Will post again after more tests, hopefully in the next 48 hours.

The extra bizarre part is that after Syphon recording files with bogus audio, playing any video on the system (related or not to the project… even YouTube) is compromised and I have to reboot.

I do know it’s not the driver for my Focusrite interface because I’m able to reproduced with internal audio only.

Just reset my system audio via terminal “sudo killall coreaudiod”, zapped NVRAM, and tried setting Live’s max buffer at 1028, and both 48k and 44.1k for Live, Loopback and system audio. Maddeningly, the problem still persists using Syphon Recorder… although at this writing, playback of other video files and streaming video seems unaffected. I still perceive that it has something to do with mismatched sample rate, bit depth the way the encoded audio is signed (little-endian, etc.), and/or the muxing process of marrying the audio sample rate to the video frame rate.

A recent switch of Syphon Recorder’s codec to Photo JPEG did seem to fix it… for a while. Why the system has reverted to misbehaving without my making any other changes I can think of is a mystery.

@jeffburger Thanks for getting back to me, and sorry you’re still having the issue. I’m also still having this problem, and I’ve tried multiple audio interfaces, capture codecs, etc. I agree that the type of distortion/glitchiness does seem like a sample rate issue. It’s recording the audio at a much faster than it’s supposed to be playing…