Single note grabber inherits midi note number and overwrites address value

#1

Hi,
First off, I think this is a problem with Ableton because it only started happening after updating to 10.1 and it’s happening with another max for live OSC device, but maybe some light could be shed on the issue. Also, sorry for the long post, especially if it’s out of LiveGrabber’s control, just trying to detail the steps.

@Mattijs This is a totally separate personal project from the other one you just solved for my day job…
I’ve been developing and updating the same template for 4 years using the grabbers and after updating to Ableton 10.1, noticed the issue in this posts title. Same problem with another custom M4L OSC device (not publicly available). So I’m guessing it’s some initialization issue or to do with the way the values are populated on load. BUT it seems to be inconsistent and I’m hunting for the reason. After noticing the first time, I tried to downgrade Ableton which was also 10.1 in the their download archive and the only option available- probably a decimal release 10.1.01 vs 10.1.02? So after I did that and opened my template, my addresses were back and I thought I solved the issue.

But then tonight I had the issue again. I tried opening the file on my Mac which is on 10.0 and the devices were missing, but I was able to replace them (which restored the addresses I’d entered) and save them as a rack with 3 chains and grabber devices on each chain. (could multiple chains and multiple note grabbers on each chain be an issue?) I THINK I dragged them in from my User Library when I originally created the template but I could be wrong. Is it essential for them to always be added from that folder? My template didn’t start that way so maybe there’s some legacy location issue, but now I always drag them in from that location.

Anyway, I sent that midi rack preset back to my PC and opened it. Again (as expected) the grabber devices were missing but after replacing them, the addresses were back. So then I open the template ALS that was killing my addresses just a few minutes before this and it just worked. I was ready to repeat the process 8 times replacing and saving from my Mac and going back to the PC but- something else I’d done had apparently got Ableton to behave properly when loading the grabbers in the template again and now everything is back to normal.

So if this happens again, I’ll try and drag a device from my user library to a track and maybe that’s the fix? I also restarted windows and it opened again fine with all my addresses instead of midi note values. Good! … But who knows what will happen in the future. It’s just scary to me because of how long I’ve been working on these settings (literally hundreds of addresses in these racks) and seeing them vanish turns my stomach.

I apologize again for the long winded post, I really love these devices though and want to help document any issues that might save others some headaches in the future.
Thanks

0 Likes

#2

Hi bframes,

Thanks for taking the time to write this down. I agree, this type of issue, where something happens -sometimes- and without clearly identifiable cause, is the worst.

So if I understand correctly:

  • when loading your set, all addresses as saved in the set are restored properly
  • while playing your set, now and then, your addresses are overwritten by incoming MIDI notes.

I tried to reproduce this but I was unable to. It would be great if you would be able to send us a small test set that exhibits this, even if it happens only once in X times, so that we can try to reproduce this.

I realize that what I am asking for could take you some time to prepare, but I am afraid that is the only way I see now in which we can start getting a grip on this issue.

Thanks!

1 Like

#3

Thanks @Mattijs,
I think the issue only happens when opening sets. It’s always every parameter of every device too, so to me, it doesn’t seem like incoming midi messages are doing it. I’ll keep an eye on it and link you to an example the next time it happens.

0 Likes

#4

Aah, I see, then I didn’t understand you correctly, I think I do get it now. So when opening a set, suddenly all your addresses are changed to incorrect values.

Could you let me know what is in the address fields after this happens, i.e. what are the addresses replaced with?

It almost sounds like there is a race condition with initialization. That would mean that if this happens, closing and re-opening the set (without saving) should place the correct addresses back into the address fields.

Thanks for reporting this. Any more information would be very welcome, in the mean time, if I find a way to reproduce this I’ll let you know.

0 Likes