Problems using enttec artnet node with Beam for Max

Screenshot 2024-06-26 at 17.05.24

Hi! Excited to get stuck into Beam for Max when I can get past past a few obstacles

This is a continuation of a post I made on FB on a thread in the Max group about Beam


  1. I cannot access the beam monitor - I get this message in the max console: “bpatcher: bpatcher: error loading patcher beam.monitor.maxpat”

  2. My enttec ode mk3 is online shown as online when I have QLab open. As soon as I close QLab, the device shows as offline in Beam and I cannot no longer send DMX via my node to my lights - Hidde suggested changing the IP of my node to the 10.x.x.x or 2.x.x.x ranges to see if that helped but it didn’t

  3. Since I tried the above step, I now get odd flashing behaviour from my lights when running my Beam patch. Nothing has changed in the patch. Only the IP changes (I switched back to the original IP & the flashing has not stopped, even after node and computer restart)


MBP 2021 M1 14" running Monterey 12.6

Max 8.6.3

I have no problems passing DMX to my fixtures in other software like EMU or QLab, only in Beam

I’ve attached a link with vids of the behaviour in case that makes it easier to diagnose - I’m by no means au fait with networking, so I’m hoping it might be a simple fix for someone with more know-how than me. Beam for Max Enttec Troubleshooting - Google Drive

I’ve also attached the Beam patch I’m working with

Any help appreciated!

All the best,


Beam test 2.maxpat (88.5 KB)

Hi Matt,

These networking issues are always difficult to debug via writing since there can be so many causes. I think it might be most productive to do a screen sharing session so that we can take a look with you. I’ll reach out directly to set something up.

In the meantime, for the enttec ode problem: there are two ways for Beam to connect to ArtNet devices. One is using it as an ‘ArtNet Node Output’ - it sounds like you’re using that option right now because that’s the one that shows the device as online/offline in Beam’s interface. The other one is the ‘ArtNet Output’ which requires you to put in the IP address manually. This one won’t show any online/offline status, but rather just trusts the user that things are connected correctly. Could you try the ‘ArtNet Output’ method and see if you can get the ode to output DMX without QLab open?