Issues with my spots being read on Ableton

Hey guys,

I’m having issues getting my spots to be read on Ableton once I’ve created them on Beam. I’m new at all this so bear with me to explain how I’ve got everything set up.

  1. In my Ableton Live Suite, I made sure to add Showsync to my preferences under the Midi section.
  2. I’ve got a USB cable running from my MacBook into an Enttec DMX USB Pro. I’ve got a 5pin DMX cable plugged into the dmx out of the interface and the other end of the 5 pin is a female 3pin connected to a male 3pin DMX cable. I’ve run that to the input of my first spot and made sure it was set on the DMX setting 14 channel starting at channel 001. I’ve then daisy chained this spot to the input of my second spot and set this spot the DMX setting 14 channel as well but this one starting at channel 015.
  3. I’ve added the specific 14 channel spot fixtures on Beam with the universe being 1 and the address being 1 and added a tag of “intimidator.”
  4. In Ableton, I’ve opened a new Live set, and added the “moving head” plug in under “Beam plugins” into a new Midi track, and then selected “intimidator” from the moving head option. However, I have no control over the spots in Ableton.
    Am I doing something wrong? Your help with this would be super appreciated as once I am able to get control over the spots, I can start mapping the spots to work alongside my tracks on Albeton. Thanks so much!

Hi @thedundiesva,

The channel 12 (Shutter / Strobe) of this fixture likely needs to be in an On state (e.g. DMX value 255) in order for the light to turn on:


Instead of using the MovingHead device, trying using the Generic device, select shutterstrobe modulation and set it to 1.00:

If the fixtures are still not responding at all, please:

  • Check if the Enttec DMX USB Pro is selected in Preferences > Output (the cogwheel in the Patch Editor).
  • Make a screenshot of the Beam’s Monitor (CMD+3) while controlling them.
  • Share the fixture patch (.sbp) and Live set (.als).

This worked perfectly yesterday! The problem I had was that I didn’t have the Enttec DMX USB Pro selected as the output on the patch editor.
Today, however, when I use the Generic device on a New midi track in Ableton, it shows “Disconnected” and won’t change. I didn’t change anything from yesterday other than unplugging the enttec dmx from my laptop and disconnecting the lights (I obviously turned the lights back on and plugged the Enttec DMX back into my laptop) but I still can’t get it to work. Any ideas?

As @Jean-Paul mentions in this post, when Beam devices are displaying Disconnected in the dropdown menus, Beam is not able to connect to Live. Try the following:

  • Please make sure that the Max 8 application is closed.
  • Run the installer again (click Beam in the menu bar, and then “Open Installer…”
  • Make sure that the Showsync Control Surface is selected in the Link / Tempo / MIDI tab in Live’s Preferences.
  • In Beam’s Preferences, make sure that Connect to remote Ableton Live is unchecked:

Screenshot 2023-08-20 at 16.32.13

If this still doesn’t help - are you by any chance also using Videosync?