Issue with instruments not triggering on M1 mac


I have a weird bug when using Beam on a M1 mac that im not experiencing when using on a intel mac.

When loading my Ableton set some of my instruments don’t trigger correctly. It seems when i open my set in Ableton the only way to ensure everything loads and triggers correctly is to delete the Beam Max instruments from each track and then cmd+z to undo the action so i retain all my automation that is connected to each instrument.
I have tried a bunch of different things like loading Beam or Ableton first and the only action that seems to ensure everything triggers correctly is to delete and undo.

Has anyone else experienced this issue. I have built quiet a complex set with a lot of automation and always opens and loads fine on my Intel based mac but keep having this issue when using a M1 mac.

Hi @destroythings,

Thanks for getting in touch about this!

  1. When you say trigger - does that refer specifically to envelopes triggered by MIDI notes? Or do you also experience device parameters (turning or automating dials) not reaching Beam?
  2. Does a device that does not trigger start to behave correctly if you disable and enable that device?
  3. Could you please share your Ableton set + Beam patch + any non-factory fixture profiles, so that we can try to reproduce this issue? If sharing publicly in the forum is not an option, you can also send it to


  1. I experience the issue with automation of the dials and triggering via midi notes. For automation is does not reach beam.
  2. Not sure about enabling and disabling the device.
  3. Will send you a email. Thanks for the response.

Great, thank you, let’s continue via e-mail. For anyone else reading this - we will post an update here as soon as we understand the issue.

I would like to add that the cause for this issue has been found and resolved. An update that fixes it will be shipped soon.

Great to hear a fix has been found. Look forward to the update

Update: this issue was fixed in Beam 1.5, so make sure to update to the latest version. Thanks again for reporting it!