External In fixed at 720p and not true 1080p

hey there,

so every time I use the “device” input page of the external in module it is always fixed at a maximum resolution of 720p. Every device from the UVC HDMI capture, to the UVC webcam, to the Mac facetime camera all present the “original” aspect in the external in with letterboxed output in 720p fit into a 1080p canvas. I.E. it presents a bunch of black frame around the “original” aspect. Currently I can just “scale to fit” in the external in module, but this is not true 1080p output. Is this a bug? it seems like I’m not actually using 1080 but just scaled up 720 when I use USB inputs. As soon as I switch to Syphon inputs, it presents it at its native resolution, even when I’m presenting the same exact input, on “syphon” its 1080p and when its “device” its 720p

if there is the best capture card to get, please let me know and I’ll get it. Currently I’m using cheap adapters because my black magic gear is unsupported on videosync.

any help on this front would be amazing, not really sure if its a bug or maybe just a limit of the system. I’m probably going to be switching to NDI and followed by NDI=syphon so that I can get true 1080 and also apply the network routing

Loving video sync !!
Thanks so much

Hi David,

Thank you for bringing this up! It indeed seems to be the case that all Device inputs are 720p with External In. I’ve added a ticket so we can change this with a future update.

thanks so much for checking in on this. Sounds good. for now 720 is totally usable, but yeah I’m very excited to use 1080 for some upcoming shows.

thanks so much!!

Just wanted to follow up on this thread — what capture cards are people out there using?

Ultimately (like @MojoDavey), I’d love to use Blackmagic cards for input. If there was a way to easily integrate Syphon Input into Videosync’s External Input module, that might be a good route to take? Black Syphon has worked pretty flawlessly with every BM device I’ve tried with it.

Just wanted to get back on this, mentioning that 1080p is supported since Videosync 1.2.

Marking this topic as resolved.

Thank you so much for implementing!!! looks great!

1 Like