Capture not recognizing ArtNet

Hi, I realize this might be a Capture question but in the Beam demo it says to connect the Capture demo project to the Artnet in the Universes window. Only the Capture file does not show the Artnet at all. I have tried many things, including not going via the ‘automatic’ option but via the wifi but it just never shows up. This means I can’t run the visualizer at all… any clues?

Hi, please try the following:

  1. Make sure Beam is not running.
  2. Start up Capture first.
  3. Now run Beam and check if the output Art-Net universe is showing up in Capture as an available input.

Hi Luka,

Yeah I’d found that previous thread but it didn’t work at first. I later tried changing the IP address on both programs to the wifi IP (instead of localhost, which seems permanently inhibited) but that didn’t work either. However I know have it running with the IP address + 255 as the last digit! I will reply to the other thread as well, might be useful for future users.

I haven’t been able to get the second universe to respond yet, but that might just be me. Thanks for the quick reply!

Hi Tessa,

Good to know you are able to receive Beam’s output in Capture by broadcasting. This is essentially what happens when you specify the “IP address + 255 as the last digit!”. Broadcasting means the Art-Net packets will be received by every IP address within the matching subnet, which can be handy in some cases, but it is not ideal as a default scenario, as it can impair the performance of your network (and in this case possibly result in a slightly less smooth visualisation), so I would still recommend trying to make it work by unicasting (sending Art-Net to a single specific address).

The reason why broadcasting always works and, on the other hand, when unicasting, the order in which Capture and Beam (or any two Art-Net applications) are started matters, is because both applications bind to the same default Art-Net port (6454) and try to receive the packets sent to that port. However, only the application which was started first and bound to that port first will receive the (unicasted) packets. So, if you start Beam before Capture, the latter will never receive Art-Net packets sent by Beam, as Beam itself is receiving and discarding them.

Simply quitting both programs, then restarting them in the right order is usually already enough, if not (in case the quitted application doesn’t release the bound port), restarting the OS and repeating should fix the issue.

As far as the address itself goes: when you mention localhost - did you specifically try to write localhost in the Art-Net output address field (that will not work) or have you tried the loopback address? Instead of you could also try, though the former should already work, provided the programs were started in the right order.

It would be much appreciated if you could try this and report back if it works. When following the steps above, we have so far always managed to get it to work, so it would be valuable to know if there is something else at play.

Still, we are aware this process could be user-friendlier and hope to offer a better way of connecting to Capture in the future.

As far as getting the second universe to work, this is something you need to specifically select and assign to an internal Capture universe:

If you map it to Universe B / 2.1-512, you will be able to patch fixtures controlled by Beam’s universe 2 by specifying addresses as B.x (where x is the DMX address):


Hope this helps!

Hi Luka, thanks for the quick and clear instructions. I have tried specifying but that doesn’t work unfortunately. I have also tried of course haha

I also remember it not working when I tried to send OSC via localhost to Resolume (that ended up working with the wifi as well). I will try later on. At the moment I am getting the connection working - incuding the second universe - with a specific address as well as broadcasting. My preferred method is to go via the local network created on my laptop, so that we can link another ableton running during the show. The weird thing is: ableton works, but the test button seems to have stopped working (for the generic rgb/rgbw bulb).

I will try running (or .255?) later today. My only gripe is that the student edition doesn’t have generic rgb (bulb) fixtures so I’m stuck opening Capture and loading three fixtures every 90 minutes but hey… at least it’s free!

Jumping in with an additional thought: could it be that networks connections are somehow blocked by other software? Perhaps a firewall or a tool like Little Snitch?

Will try little snitch tomorrow. It definitely feels like localhost is jammed up with something!

  • Trying to disable any software like Little Snitch sounds like a good thing to try! When you mention “the local network created on my laptop”, is this a macOS computer-to-computer Wi-Fi network or are you connecting via a switch/router/directly using a cable? What happens if you momentarily disable any of that and only enable your computer’s Wi-Fi, restart your computer and then repeat the procedure ( It is good to know you already have a way that works, but it would still be great to get to the bottom of this :slight_smile:
  • As mentioned in the other thread, the Test button at the moment doesn’t have any effect on fixture profiles that do not contain a dimmer channel, such as Generic RGB and Generic RGBW.
    An update (1.5.2) that will make this work will be out in the coming weeks.
  • Within the Capture Student Edition you could try ADJ Dotz Matrix, which doesn’t look exactly like a bulb, but it has a 3-channel mode with Red/Green/Blue - just like Generic RGB.

Two threads kind of intermingling but to respond in reversed order:

  • The colordash lamp responds to rgb+w. The wash responds to rgb only. Other lamps with more channels do not respond to rgb (ie. the colors are not on the first three channels).

  • Test button understood.

  • The connection runs when I connect to the specific IP. Whether it be via the Wifi or via a local created notwork on my Mac. I don’t have little snitch running, I was gonna install it to block all other messages. But on two laptops now it’s been the case that leave Capture on ‘Automatic’ for the IP connection means it is not connecting to Beam. The only way that works is:

  1. Open Capture, go to Connectivity Options in the universes tab (three dots)
  2. Instead of Automatic, click on it and select the wifi
  3. Restart Capture
  4. Go to Beam: type in the exact wifi address in options (and press enter, or it wont save)
  5. Quit beam, quit capture, restart capture, restart beam
  6. Load a fixture list (it won’t recognize artnet if there is no fixture loaded!)
  7. Only now start ableton and voila.

This is why I’m happy with the rgb+w lamp in the student edition, because having to do this every time I arrive somewhere with a new wifi and then every 60-90mins with the demo capture was absolutely horrible haha

EDIT: About the localhost: I’m assuming I would have to leave Capture on “automatic” as there is no option to choose as an address, just auto or wifi. I have not gotten this to work on two different macbooks so currently just working with the above solution.

Hey Tessa, glad to hear you were able to work around most of these things and thanks for thoroughly sharing the process.

As far as connecting to Capture goes - while you might already feel satisfied with the current solution, we would be happier knowing that you had a smoother ride. We’ve been able to make this work without having to go through all this with many computers, but it seems like there are still some factors at play we are not yet aware of. It would be valuable to better understand this and see if there is something more we can do, so I would like to propose a video call - I’ve sent you a DM.

Update for anyone coming across this thread in the future: we had a call and sending Art-Net to Capture via after all ended up working using the above steps. We were not able to determine why exactly this initially didn’t work in this case, perhaps another unrelated issue that was resolved in the meantime.