Beam.core not loading in Max

Tried going through some of the object references for Beam For Max, but beam.core isn’t loading no matter what I do. Seems like a great product based on examples, but I can’t justify dropping the money on a full license if the demo doesn’t work. Any ideas what I might be doing wrong?

Error 126 loading external beam.core

Ableton: 11.3.20
Max: 8.5.6

Hi @MusicianAtHome, thanks for the interest in Beam for Max!

Are you running macOS or Windows? What version?

Hi, Luka. I’ve only tried on Windows 10 so far.

I haven’t been able to reproduce this on Windows 10 yet, but would like to understand why this is happening. We will investigate this further and get back to you asap. Thanks for reporting this issue!

I have the same problem. the core is not loading.

Win 11 / Max 8.6.0

If i can help adding further information please tell me!

Hi again @Robert and @MusicianAtHome,

We have finally succeeded to reproduce this issue, and will work on getting it fixed asap.

In the meanwhile, a temporary solution is to ensure the ftd2xx.dll is in your PATH. This file is present in the Beam for Max/externals folder:

image

You can simply add the externals folder to the PATH, see this article: Add to the PATH on Windows 10 and Windows 11 | Architect Ryan

Thank you for reporting!

@Luka Perfect, thanks for investigating and figuring out a temporary fix!

1 Like