Ableton Live 11 -> Resolume 7 OSC link not working

Hi guys!
I’m wanting to use my Ableton to trigger clips in Resolume 7. I have downloaded the M4L patches, added the dispatcher on the master and Clip Launcher on a track, etc etc, sending to the correct port - 7000. Enabled OSC receiving in Resolume, followed all the steps correctly as far as I can tell, but it’s not working. Hooked up a OSC monitoring app and it’s not detecting any OSC messages on port 7000. What could be going wrong? Please help :slight_smile:

Best wishes

Hi TessaRose,

Thanks for getting in touch about this.

To make sure I understand you correctly, I replicated a basic setup with the latest versions of Arena, Live and the Resolume M4L patches. For me this works as expected. Below is a screenshot in which the buttons that are linked are highlighted with a red square.

It would be great to know if the same setup works for you.

If it doesn’t, the first thing I’d be interested to know about is if there are any errors in the Max devices on your system. To find out about that, you can right-click the title bar of one of the Max for Live devices and choose Open Max Window. If there are any errors there, it would be great of you could send us a screenshot.


Hi everybody,
Same issue here, I put the video dispatcher on the master & the launcher on an audio clip in a Live session, but it does not trigger anything on the Resolume side.
I have error messages in M4L as displayed in the pics below.

Many thks for your help !

Hi betnwaar, thanks for weighing in and sharing a screenshot.

It looks like the error messages in your Max Window are caused by Livesync Follower, which is something I’d be interested to look into separately.

Regarding the issue with the Resolume plugins, from your screenshot I can’t determine what the issue could be. For me a typical setup with the Clip Launcher works as expected.

Would you be able to try the setup I made a screenshot of in my previous post and see if that works for you?

I am so sorry for my radio silence!!! I have been away, will send a proper screenshot tomorrow, thank you so much for getting back to me!

Heya, just wanted to let you know it was solved by Darius (my partner in crime). Turns out the IAC driver wasn’t active on my mac, which apparently killed the OSC messages as well. Weirdly enough it won’t ping on the localhost but does ping on the IP address that Resolume gives (192.168…)

Anyway, solved!